Welcome, Guest
Username: Password: Remember me
A forum for owners and fans of Chrysler and Force engines.
  • Page:
  • 1

TOPIC: Water Circulation

Water Circulation 3 years 2 months ago #113951

  • Kevchoe
  • Kevchoe's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 34
  • Karma: 1
  • Thank you received: 0
I have a '66 105 hp outboard. Bought at auction recently. Its pretty close to lake ready. Got the engine running but it won't circulate. Before we ran it, we put a new impeller on. The water just squirts out the clamps. Any thoughts? Is the impeller just needing to get set in and turning? Should i get it on the water and crank it to break it loose?

Please Log in to join the conversation.

Re:Water Circulation 3 years 1 month ago #114182

  • Robby321
  • Robby321's Avatar
  • Offline
  • Contributing Member
  • Contributing Member
  • Posts: 839
  • Karma: 42
  • Thank you received: 2
As no response any might as well chime in. You ARE on muffs and motor running right? It should pump instant, or ya screwed something up the install. And putting it in the water will NOT help. Did you forget the "Key" that locks the impeller to the DS?

Best I can say the moment........

Please Log in to join the conversation.

Re:Water Circulation 3 years 1 month ago #114191

  • l98tpi
  • l98tpi's Avatar
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 223
  • Karma: 16
  • Thank you received: 0
I don't understand "The water just squirts out the clamps." You could run it in a barrel or big trash can. But if it wont start pumping on the hose pressure, you likely have something assembled wrong as Robby pointed to.

Please Log in to join the conversation.

Boats: 76 Chrysler Conqueror S3, 61 Larson Playmate. Outboards: 76 Chrysler 105, 70 Chrysler 70, 57 Evinrude Bigtwin 35, 80 Johnson 35 looper, 74 Chrysler 45, 67 Mercury 650SS, and others.

Re:Water Circulation 3 years 1 month ago #114397

  • Kevchoe
  • Kevchoe's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 34
  • Karma: 1
  • Thank you received: 0
You were right Rob. Totally had it installed wrong. I had some help when I put the new impeller on and it was done all wrong. After reading everything I could find I just went out and put my thinking cap on and figured it out.

Please Log in to join the conversation.

Re:Water Circulation 3 years 1 month ago #114402

  • Robby321
  • Robby321's Avatar
  • Offline
  • Contributing Member
  • Contributing Member
  • Posts: 839
  • Karma: 42
  • Thank you received: 2
Good to know! And don't feel bad as "been there and done it too"

Wish the best to ya!

Please Log in to join the conversation.

Re:Water Circulation 3 years 1 month ago #114654

  • l98tpi
  • l98tpi's Avatar
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 223
  • Karma: 16
  • Thank you received: 0
Glad you caught this.
Did you notice how small the Chrysler impeller is compared to a Mercury? Same hp. half the size. Shocked me the first time I saw it.

Please Log in to join the conversation.

Boats: 76 Chrysler Conqueror S3, 61 Larson Playmate. Outboards: 76 Chrysler 105, 70 Chrysler 70, 57 Evinrude Bigtwin 35, 80 Johnson 35 looper, 74 Chrysler 45, 67 Mercury 650SS, and others.
  • Page:
  • 1
Time to create page: 0.148 seconds

FG Login

Donate

Please consider supporting our efforts.

Glassified Ads

WTB Tomahawk Boat Parts
( / Wanted)

noimage
10-13-2018

FiberGoogle

Quick Search

Who's Online

We have 2739 guests and 4 members online