Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Volvo/Penta 280 broken hose ?

Volvo/Penta 280 broken hose ? 7 months 1 day ago #144833

I've never had an I/O before and I cannot identify this hose(see attainments). Does anyone know the purpose of this hose. It looks like it should exit from the hole in the drive mount, but for likes of me I cannot find it's origin inside the bilge, or attached to any part of the engine,heat exchangers or water pump system. The motor (Ford 351 engine w/Volvo 240A marine, and Volvo 280 I/O) runs fine, correct temp no overheating. Immediately after pulling the boat out of the water, a quantity of water(1/2 gal or more) drains from this broken hose at the ramp?
I ran it today on the muffs to see what it does. Water and exhaust come out of the upper main exhaust port,but this unknown hose also cycles water out. I don't want to keep running the boat if this could cause trouble. .Thanks for any knowledgeable response.

Please Log in or Create an account to join the conversation.

Volvo/Penta 280 broken hose ? 2 months 4 weeks ago #145569

The rubber tube mounts between your exhaust "Y" pipe and the transom shield, that's way you don't see it inside the boat anywhere. The tube carries water water out and off to the side lowering the back pressure in the exhaust side of the outdrive. Volvo part # 843235. if it's still intact otherwise I wouldn't worry about it, not easy to change. You would need to pull exhaust bellows and "Y" pipe if you can get to it.

Please Log in or Create an account to join the conversation.

Volvo/Penta 280 broken hose ? 2 months 1 week ago #145640

Thanks for the reply. Sounds like I can just leave it be, But can water be seeping back into my engine block this way?

Please Log in or Create an account to join the conversation.

Volvo/Penta 280 broken hose ? 2 months 1 week ago #145647

No way water can back up, it's part of the "Y" pipe going up to your exhaust manifolds. Above the water line.

Please Log in or Create an account to join the conversation.

Volvo/Penta 280 broken hose ? 2 months 1 week ago #145661

I'm getting H20 in my oil. I used a Stop leak and it sort of helped for awhile ,but now it's back again. Don't know how to find where it's coming from? Cracked Head? Heat exchangers, Plumbing? No sch thing as an easy fix. I've winterized it for now but I'll have to do something come spring. Any ideas?

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.182 seconds

FG Login

Donate

Please consider supporting our efforts.

Glassified Ads

1965 Hydrodyne
( / Boats)

1965 Hydrodyne
01-12-2022

MERCURY OUTBOARD LOWER UNIT TOOLS
( / Parts / Miscellaneous)

MERCURY OUTBOARD LOWER UNIT TOOLS
01-06-2022

OMC PROP 15X 17
( / Parts / Miscellaneous)

OMC PROP 15X 17
01-06-2022

FiberGoogle

Who's Online

We have 29979 guests and 7 members online