Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: 1969 Merc 1250 - No Spark

1969 Merc 1250 - No Spark 2 months 2 weeks ago #140502

New to me boat but have no history but looks like not used for a long duration. Has twin 1250 Mercs - 1969. Motors look very original....and pretty clean. Got one running after replacing a few rotted wires....only ran it for a short time as waiting for new impellers. Second one has no spark to all plugs. Checked all grounds, belt is good, disconnected mercury switch...still no joy. Have a working motor so exchanged coil, then switch box...still no spark. What next.....trigger? Is there a test for it? Looked around and don’t see any on eBay or a few suppliers I tried. Looks like CDI Electronics maybe had them in the past but not sure if they still have?
Would appreciate some guidance/ knowledge.....thanks in advance.
Any sources of trigger 2918A3 out there?

Dave

Please Log in to join the conversation.

1969 Merc 1250 - No Spark 2 months 2 weeks ago #140506

  • Dr.Go!
  • Dr.Go!'s Avatar
  • Offline
  • Contributing Member
  • Contributing Member
  • Posts: 1364
  • Karma: 16
  • Thank you received: 78
Looks like ED-MC found your post on the main forum and got you some good answers. I just wanted to be sure you got some Mercury people looking at your question in case some may not visit each forum. I will also save ED-MCs information for my own future reference.

Please Log in to join the conversation.

Dr.Go!
  • Page:
  • 1
Time to create page: 0.118 seconds

FG Login

Donate

Please consider supporting our efforts.

Glassified Ads

12 ft Crestliner Jetstreak
( / Boats)

12 ft Crestliner Jetstreak
10-19-2019

Canadian Built Runabout
( / Boats)

Canadian Built Runabout
10-17-2019

ISO: Mercury Tower of Power
( / Wanted)

ISO: Mercury Tower of Power
10-14-2019

FiberGoogle

Quick Search

Who's Online

We have 2050 guests and 2 members online