Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: 50hp loss of RPM

50hp loss of RPM 4 months 3 weeks ago #136800

  • propnut
  • propnut's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 165
  • Karma: 2
  • Thank you received: 0
hi, i have a 50hp serial# 2860630 with a lightning energizer ignition that i picked up over the winter. It fired right up for me so i thought i would go through it and get it ready for summer. I rewired it , replaced fuel lines, impeller and rebuilt the fuel pump. It ran ok in the tank in my yard. On the first few trips out it ran fine, idle was good and good top end. Then it wouldn'T idle but still ran good in the higher rpms. i cleaned the carbs and removed the distributor cap to make sure everything was good there. The idle smoothed out but i have lost my high rpms. i have cleaned the carbs again ,checked the timing and made sure the butterflies are opening fully. I still can't get it past about 400 rpms Compression is even in all 4 cylinders at 125 psi. . Any ideas? thanks in advance

Please Log in to join the conversation.

50hp loss of RPM 4 months 3 weeks ago #136804

Once you get it started, and the throttle linkage is opened enough that the beast should be running much faster than 400 RPMs,
Take a can of aerosol type carburetor cleaner with the extension tube, and squirt a brief shot into the top carburetor, and see if the RPMs momentarily pick up.
Then do the same to the bottom carburetor.
If you get a momentary rise in RPMs at either carburetor, you have a fuel delivery issue.
doc

Please Log in to join the conversation.

50hp loss of RPM 4 months 3 weeks ago #136809

  • propnut
  • propnut's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 165
  • Karma: 2
  • Thank you received: 0
Thanks doc, I meant to type 4000 rpm, it idles fine accelerates like it should but just doesn't get past about 4000 rpm. I've pumped the primer bulb as it accelerates, maybe I will clean the carbs again. Thanks

Please Log in to join the conversation.

50hp loss of RPM 4 months 2 days ago #136952

  • propnut
  • propnut's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 165
  • Karma: 2
  • Thank you received: 0
I found the issue. After cleaning the carbs and remounting them when i mounted the filter cover on the bottom carb the fuel line elbow was pushed over to far and it prevented the bottom butterfly from opening. I took it out yesterday and it ran like a top.

Please Log in to join the conversation.

  • Page:
  • 1
Time to create page: 0.111 seconds

FG Login

Donate

Please consider supporting our efforts.

Glassified Ads

1967 Glastron
( / Boats)

1967 Glastron
11-09-2018

1961 Arena Craft
( / Boats)

1961 Arena Craft
11-09-2018

FiberGoogle

Quick Search

Who's Online

We have 2870 guests and 7 members online