Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: 90hp mercury hard starting and no power

90hp mercury hard starting and no power 5 months 1 week ago #133337

ok starting to get a little frustrated here.. i have a 82 90hp mercury.. last year it ran fine.. just took it out today.. motor wont rev over 2k.. and hard to start... carbs were rebuilt last year.. along with fuel pump and tune up..
i had a issue with the carbs flooding.. been messing with the float level.. i'm at my wits end.. i have no one around me that has a clue with older motors.. and working on this by myself...

Please Log in to join the conversation.

90hp mercury hard starting and no power 5 months 1 week ago #133340

  • ed-mc
  • ed-mc's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 982
  • Karma: 217
  • Thank you received: 22
It could be electronics. You can take resistance readings of the high and low-speed stator windings to make sure they're in spec.

I've had a spate of bad ADI ign coils lately, even though the plug would spark laying on the block, it would not fire the cylinder. Later coils are better-built and not too expensive.

You'll probably need to buy a DVA adapter to take voltage readings on the ign system, but meanwhile download the CDI Electronics troubleshooting guide and check out the resistance tests for Mercury ADI (Alternator-Driven Ignition) motors:

www.cdielectronics.com/support/

www.amazon.com/Electronic-Specialties-DVA-Adaptor/dp/B0093U3TFG?tag=duckduckgo-d-20

Also available on ebay but it won't let me post a link to that.

HTH.............ed

Please Log in to join the conversation.

90hp mercury hard starting and no power 5 months 1 week ago #133346

ok... DVA adapter ordered...

Please Log in to join the conversation.

90hp mercury hard starting and no power 5 months 1 week ago #133355

ed-mc,
I'm unable to print the Mercury page.
My old copy is getting pretty greasy & tattered.
Please send me a JPG image or something I can print.

vintagerunner,
While you are waiting for your DVA adapter,...Take out all the spark plugs, then put the spark plugs back into their spark plug wires.
Then make sure and ground all (6) spark plugs to engine (-) ground.
If you don't ground all (6) during the testing, you can stress the ignition components, and possibly damage them.
Then check for spark, and identify which spark plug isn't firing.
The results might be a clue as to which ones are not firing.
doc

Please Log in to join the conversation.

90hp mercury hard starting and no power 5 months 1 week ago #133361

  • ed-mc
  • ed-mc's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 982
  • Karma: 217
  • Thank you received: 22
Doc, You've Got Mail!............ed

Please Log in to join the conversation.

90hp mercury hard starting and no power 5 months 1 week ago #133363

ok well i went out today and pulled the plugs.. 2,4,6 not firing.. plugs looked like new... did compression test 150 all 6 holes
checked for spark .. nothing on 2,4,6.. pulled the switch box off and popped on a spare.. still no spark.. switched 2 original boxes top to bottom.. now no spark on 1,3,5
so grabbed another box from my parts bin.. and popped it on the top..had a friend hit the key and now have spark... hooked up water and fired right up like i was used to...now getting ready to head out and water test it again in a few minutes.. not going to chance it and ordering 2 new boxes tonight.. dont want to break down with our grand daughter on board..
wish me luck.. i'll post how i made out later..

Please Log in to join the conversation.

90hp mercury hard starting and no power 5 months 1 week ago #133370

bad switch box it was.. runs like normal now.. now just need to re-adjust the idle.. since i had set it while it was running on 3 cyl's its a little high now.. not a issue.. i'll get that reset after dinner tonight..

Please Log in to join the conversation.

  • Page:
  • 1
Time to create page: 0.157 seconds

FG Login

Donate

Please consider supporting our efforts.

Glassified Ads

1975 Century Resorter
( / Boats)

1975 Century Resorter
01-19-2018

1958 OWENS runabout & 1958/59 CUTTER runabout
( / Boats)

1958 OWENS runabout & 1958/59 CUTTER runabout
01-18-2018

Seeking a 1960 40hp Evinrude Lark II
( / Engines)

noimage
01-12-2018

FiberGoogle

Quick Search

Who's Online

We have 5163 guests and 9 members online